Billing Hub periodic slow response times

Incident Report for Flight Schedule Pro

Resolved

This issue has been resolved
Posted Apr 08, 2025 - 14:07 CDT

Monitoring

We have implemented a change to resolve the sporadic site slowness and are monitoring to ensure the issue is resolved.
Posted Apr 08, 2025 - 13:51 CDT
This incident affected: Billing Hub (Billing & POS).