Schedule issues

Incident Report for Flight Schedule Pro

Resolved

The incident has been resolved.
Posted Apr 28, 2026 - 14:07 CDT

Investigating

We are currently investigating an issue that is impacting the scheduling system.
Posted Apr 28, 2026 - 14:01 CDT
This incident affected: Scheduling Hub.